summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-08-02 10:52:13 +0100
committerGitHub <noreply@github.com>2023-08-02 10:52:13 +0100
commitd38943aadcd30aa2959a515e5526b882415ab31e (patch)
treeaf18e72654c14cdf3baaa07c594e2600ca079d8a /Cargo.toml
parent51e51da89687dc4678f64377e1c9ef7a74fb410e (diff)
downloadcandle-d38943aadcd30aa2959a515e5526b882415ab31e.tar.gz
candle-d38943aadcd30aa2959a515e5526b882415ab31e.tar.bz2
candle-d38943aadcd30aa2959a515e5526b882415ab31e.zip
Add version numbers for all the candle crates (#303)
* Switch to candle-gemm for the time being. * Add the missing versions.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 2 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8738461b..0347ffe9 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,10 +18,8 @@ anyhow = { version = "1", features = ["backtrace"] }
byteorder = "1.4.3"
clap = { version = "4.2.4", features = ["derive"] }
cudarc = { version = "0.9.13", features = ["f16"] }
-# TODO: Switch back to the official gemm implementation once the following are available.
-# https://github.com/sarah-ek/gemm/pull/8.
-# https://github.com/sarah-ek/gemm/pull/9.
-gemm = { git = "https://github.com/LaurentMazare/gemm.git" }
+# TODO: Switch back to the official gemm implementation once it has caught up.
+gemm = { version = "0.15.5", package = "candle-gemm" }
hf-hub = "0.2.0"
half = { version = "2.3.1", features = ["num-traits", "rand_distr"] }
intel-mkl-src = { version = "0.8.1", features = ["mkl-static-lp64-iomp"] }