diff options
author | Laurent Mazare <laurent.mazare@gmail.com> | 2023-08-11 06:51:58 +0200 |
---|---|---|
committer | GitHub <noreply@github.com> | 2023-08-11 05:51:58 +0100 |
commit | e29c7809ecbfccc60e73a1944bfdbe60805cc905 (patch) | |
tree | 0178fbfaed34848c8602738903ffad4b1fd6b499 /Cargo.toml | |
parent | a325c1aa50fe31679dc24b6e6a796e9470698059 (diff) | |
download | candle-e29c7809ecbfccc60e73a1944bfdbe60805cc905.tar.gz candle-e29c7809ecbfccc60e73a1944bfdbe60805cc905.tar.bz2 candle-e29c7809ecbfccc60e73a1944bfdbe60805cc905.zip |
Parallelise the CPU kernels for the conv ops. (#401)
* Parallelise the conv2d op.
* Tighter control on threading.
* Also parallelise conv1d.
* Add some safety comment.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -43,6 +43,7 @@ num_cpus = "1.15.0" num-traits = "0.2.15" rand = "0.8.5" rand_distr = "0.4.3" +rayon = "1.7.0" safetensors = "0.3.1" serde = { version = "1.0.171", features = ["derive"] } serde_json = "1.0.99" |