summaryrefslogtreecommitdiff
path: root/candle-core/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-07-10 15:52:03 +0100
committerGitHub <noreply@github.com>2023-07-10 15:52:03 +0100
commit548b1df7ea8835f171f04ce28f778a30e8b31f9c (patch)
tree3957f895cc2da7324af5b9c637187d3162e38e11 /candle-core/Cargo.toml
parent221b1aff6594acd6d030c5131dba388590d1917f (diff)
downloadcandle-548b1df7ea8835f171f04ce28f778a30e8b31f9c.tar.gz
candle-548b1df7ea8835f171f04ce28f778a30e8b31f9c.tar.bz2
candle-548b1df7ea8835f171f04ce28f778a30e8b31f9c.zip
Remove the dependency to blas and use mkl directly. (#125)
Diffstat (limited to 'candle-core/Cargo.toml')
-rw-r--r--candle-core/Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/candle-core/Cargo.toml b/candle-core/Cargo.toml
index 27e85eee..91ca0cff 100644
--- a/candle-core/Cargo.toml
+++ b/candle-core/Cargo.toml
@@ -11,7 +11,6 @@ license = "MIT/Apache-2.0"
readme = "README.md"
[dependencies]
-blas = { version = "0.22.0", optional = true }
byteorder = "1.4.3"
candle-kernels = { path = "../candle-kernels", optional = true }
# Re-enable this once 0.9.13 as been released as it would include the cublas-f16 changes
@@ -22,6 +21,7 @@ cudarc = { git = "https://github.com/LaurentMazare/cudarc.git", branch = "cublas
gemm = { git = "https://github.com/LaurentMazare/gemm.git", branch = "f16-vectorize-pack" }
half = { version = "2.3.1", features = ["num-traits"] }
intel-mkl-src = {version="0.8.1", optional=true, features = ["mkl-dynamic-lp64-iomp"]}
+libc = { version = "0.2.147", optional = true }
memmap2 = "0.7.1"
num-traits = "0.2.15"
num_cpus = "1.15.0"
@@ -35,4 +35,4 @@ anyhow = { version = "1", features = ["backtrace"] }
[features]
default = ["cuda"]
cuda = ["dep:cudarc", "dep:candle-kernels"]
-mkl = ["dep:blas", "dep:intel-mkl-src"]
+mkl = ["dep:libc", "dep:intel-mkl-src"]