summaryrefslogtreecommitdiff
path: root/candle-core/Cargo.toml
diff options
context:
space:
mode:
authorNicolas Patry <patry.nicolas@protonmail.com>2023-12-20 15:37:31 +0100
committerGitHub <noreply@github.com>2023-12-20 15:37:31 +0100
commit9fc210fae8175a180dba8c28aa8e5975868a237c (patch)
tree5c009b11e1c11f20c99d1546849a00a063e068c0 /candle-core/Cargo.toml
parent96f1a28e390fceeaa12b3272c8ac5dcccc8eb5fa (diff)
parent9b5e4843a63180a2803b1e836b4ca90f14281d03 (diff)
downloadcandle-9fc210fae8175a180dba8c28aa8e5975868a237c.tar.gz
candle-9fc210fae8175a180dba8c28aa8e5975868a237c.tar.bz2
candle-9fc210fae8175a180dba8c28aa8e5975868a237c.zip
Merge pull request #1318 from huggingface/metal4
Starting to fix some tests.
Diffstat (limited to 'candle-core/Cargo.toml')
-rw-r--r--candle-core/Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/candle-core/Cargo.toml b/candle-core/Cargo.toml
index 42e5be2a..52e79a5a 100644
--- a/candle-core/Cargo.toml
+++ b/candle-core/Cargo.toml
@@ -34,6 +34,8 @@ zip = { workspace = true }
[dev-dependencies]
anyhow = { workspace = true }
clap = { workspace = true }
+criterion = { workspace = true }
+
[features]
default = []
@@ -42,3 +44,8 @@ cudnn = ["cuda", "cudarc/cudnn"]
mkl = ["dep:libc", "dep:intel-mkl-src"]
accelerate = ["dep:libc", "dep:accelerate-src"]
metal = ["dep:metal", "dep:candle-metal-kernels"]
+
+[[bench]]
+name = "matmul"
+harness = false
+