summaryrefslogtreecommitdiff
path: root/candle-core/Cargo.toml
diff options
context:
space:
mode:
authorNicolas Patry <patry.nicolas@protonmail.com>2023-06-27 11:57:27 +0200
committerNicolas Patry <patry.nicolas@protonmail.com>2023-06-27 11:57:27 +0200
commitd7f729fb8f1d4b224f18ca3d7ae1163afe57a094 (patch)
treef60643690f3c7f34ae64923771cd568d75d85f5c /candle-core/Cargo.toml
parent6c4a960b15404b9307328fa4e2c929f813b6b092 (diff)
downloadcandle-d7f729fb8f1d4b224f18ca3d7ae1163afe57a094.tar.gz
candle-d7f729fb8f1d4b224f18ca3d7ae1163afe57a094.tar.bz2
candle-d7f729fb8f1d4b224f18ca3d7ae1163afe57a094.zip
Refactor the hierarchy.
Diffstat (limited to 'candle-core/Cargo.toml')
-rw-r--r--candle-core/Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/candle-core/Cargo.toml b/candle-core/Cargo.toml
new file mode 100644
index 00000000..97215953
--- /dev/null
+++ b/candle-core/Cargo.toml
@@ -0,0 +1,32 @@
+[package]
+name = "candle"
+version = "0.1.0"
+edition = "2021"
+
+description = "Minimalist ML framework."
+repository = "https://github.com/LaurentMazare/candle"
+keywords = ["blas", "tensor", "machine-learning"]
+categories = ["science"]
+license = "MIT/Apache-2.0"
+readme = "README.md"
+
+[dependencies]
+safetensors = "0.3.1"
+thiserror = "1"
+cudarc = { version = "0.9.9", optional = true, features = ["f16"] }
+candle-kernels = { path = "../candle-kernels", optional = true }
+gemm = "0.15.4"
+zip = { version = "0.6.6", default-features=false }
+byteorder = "1.4.3"
+half = { version = "2.3.1", features = ["num-traits"] }
+num-traits = "0.2.15"
+
+[dev-dependencies]
+anyhow = "1"
+clap = { version = "4.2.4", features = ["derive"] }
+rand = "0.8.5"
+tokenizers = { version = "0.13.3", default-features=false, features=["onig"] }
+
+[features]
+default = ["cuda"]
+cuda = ["dep:cudarc", "dep:candle-kernels"]