summaryrefslogtreecommitdiff
path: root/candle-examples/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-08-09 16:26:44 +0200
committerGitHub <noreply@github.com>2023-08-09 15:26:44 +0100
commit3a62aee91ffd4b73eb7811cf08094ab1910a5256 (patch)
tree201182e3f3bbbc522d177339d75a71a329035a92 /candle-examples/Cargo.toml
parentbe21d7e75a38b2d383ae64f028ded2d4ce3c473d (diff)
downloadcandle-3a62aee91ffd4b73eb7811cf08094ab1910a5256.tar.gz
candle-3a62aee91ffd4b73eb7811cf08094ab1910a5256.tar.bz2
candle-3a62aee91ffd4b73eb7811cf08094ab1910a5256.zip
Write the generated images using the image crate. (#363)
* Use the image crate to write the generated images. * Make the dependency optional.
Diffstat (limited to 'candle-examples/Cargo.toml')
-rw-r--r--candle-examples/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/candle-examples/Cargo.toml b/candle-examples/Cargo.toml
index f3a4e325..84115dd5 100644
--- a/candle-examples/Cargo.toml
+++ b/candle-examples/Cargo.toml
@@ -23,6 +23,7 @@ num-traits = { workspace = true }
intel-mkl-src = { workspace = true, optional = true }
cudarc = { workspace = true, optional = true }
half = { workspace = true, optional = true }
+image = { workspace = true, optional = true }
[dev-dependencies]
anyhow = { workspace = true }
@@ -51,3 +52,7 @@ nccl = ["cuda", "cudarc/nccl", "dep:half"]
[[example]]
name = "llama_multiprocess"
required-features = ["cuda", "nccl", "flash-attn"]
+
+[[example]]
+name = "stable-diffusion"
+required-features = ["image"]