summaryrefslogtreecommitdiff
path: root/candle-examples/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-08-14 21:30:41 +0100
committerGitHub <noreply@github.com>2023-08-14 21:30:41 +0100
commit90374097dc99b14dfc935318a18c21fc5909291f (patch)
tree61a45bfa840f4551a5581a4ab169dce23b13db4b /candle-examples/Cargo.toml
parentc84883ecf2c240792392353175b634f6ec92a011 (diff)
downloadcandle-90374097dc99b14dfc935318a18c21fc5909291f.tar.gz
candle-90374097dc99b14dfc935318a18c21fc5909291f.tar.bz2
candle-90374097dc99b14dfc935318a18c21fc5909291f.zip
Cudnn support (#445)
* Add a cudnn feature to be used for conv2d. * Allocate the proper workspace. * Only create a single cudnn handle per cuda device. * Proper cudnn usage. * Bugfix.
Diffstat (limited to 'candle-examples/Cargo.toml')
-rw-r--r--candle-examples/Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/candle-examples/Cargo.toml b/candle-examples/Cargo.toml
index 54eb0be6..45216a5c 100644
--- a/candle-examples/Cargo.toml
+++ b/candle-examples/Cargo.toml
@@ -47,6 +47,7 @@ anyhow = { workspace = true }
default = []
accelerate = ["dep:accelerate-src", "candle/accelerate", "candle-nn/accelerate", "candle-transformers/accelerate"]
cuda = ["candle/cuda", "candle-nn/cuda", "candle-transformers/cuda"]
+cudnn = ["candle/cudnn"]
flash-attn = ["cuda", "dep:candle-flash-attn"]
mkl = ["dep:intel-mkl-src", "candle/mkl", "candle-nn/mkl", "candle-transformers/mkl"]
nccl = ["cuda", "cudarc/nccl", "dep:half"]