summaryrefslogtreecommitdiff
path: root/candle-flash-attn/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-07-26 14:16:37 +0100
committerGitHub <noreply@github.com>2023-07-26 14:16:37 +0100
commit2ce5f12513d0dafb04c7e345da9d4fba566cfa16 (patch)
treed8370aa035f667905e6f033e99e08fd93e677041 /candle-flash-attn/Cargo.toml
parentfa2b64d678ca83e2fbc3dabdecffbc778d5b067d (diff)
downloadcandle-2ce5f12513d0dafb04c7e345da9d4fba566cfa16.tar.gz
candle-2ce5f12513d0dafb04c7e345da9d4fba566cfa16.tar.bz2
candle-2ce5f12513d0dafb04c7e345da9d4fba566cfa16.zip
Again set a few extra params in flash-attn. (#245)
* Again set a few extra params. * Use the appropriate kernel sizes. * Add all the kernel sizes. * Parallel compiling. * Reduce the amount of parallelism. * Add the missing kernel. * Fix a typo. * Remove bf16 support for now.
Diffstat (limited to 'candle-flash-attn/Cargo.toml')
-rw-r--r--candle-flash-attn/Cargo.toml2
1 files changed, 2 insertions, 0 deletions
diff --git a/candle-flash-attn/Cargo.toml b/candle-flash-attn/Cargo.toml
index 25201a0e..9d21cf4a 100644
--- a/candle-flash-attn/Cargo.toml
+++ b/candle-flash-attn/Cargo.toml
@@ -16,3 +16,5 @@ half = { version = "2.3.1", features = ["num-traits"] }
[build-dependencies]
anyhow = { version = "1", features = ["backtrace"] }
+num_cpus = "1.15.0"
+rayon = "1.7.0"