summaryrefslogtreecommitdiff
path: root/candle-onnx/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-11-06 07:45:07 +0100
committerGitHub <noreply@github.com>2023-11-06 07:45:07 +0100
commit2a45bcf94315293e6a85491c11d588e089e056c0 (patch)
tree0bd4538d091da4a9f1019afc90373343040b5301 /candle-onnx/Cargo.toml
parent47f4ddb0115b5bc6e995ab14af3cc7507b59c497 (diff)
downloadcandle-2a45bcf94315293e6a85491c11d588e089e056c0.tar.gz
candle-2a45bcf94315293e6a85491c11d588e089e056c0.tar.bz2
candle-2a45bcf94315293e6a85491c11d588e089e056c0.zip
Put the onnx example behind a feature flag. (#1276)
* Put the onnx example behind a feature flag. * Exclude the onnx bits from the workspace. * README tweaks.
Diffstat (limited to 'candle-onnx/Cargo.toml')
-rw-r--r--candle-onnx/Cargo.toml19
1 files changed, 10 insertions, 9 deletions
diff --git a/candle-onnx/Cargo.toml b/candle-onnx/Cargo.toml
index a4817e43..a0f5b736 100644
--- a/candle-onnx/Cargo.toml
+++ b/candle-onnx/Cargo.toml
@@ -1,12 +1,13 @@
[package]
name = "candle-onnx"
-version.workspace = true
-edition.workspace = true
-description.workspace = true
-repository.workspace = true
-keywords.workspace = true
-categories.workspace = true
-license.workspace = true
+version = "0.3.0"
+edition = "2021"
+
+description = "ONNX support for Candle"
+repository = "https://github.com/huggingface/candle"
+keywords = ["blas", "tensor", "machine-learning"]
+categories = ["science"]
+license = "MIT OR Apache-2.0"
[dependencies]
candle = { path = "../candle-core", version = "0.3.0", package = "candle-core" }
@@ -17,6 +18,6 @@ prost = "0.12.1"
prost-build = "0.12.1"
[dev-dependencies]
-anyhow = { workspace = true }
-clap = { workspace = true }
+anyhow = { version = "1", features = ["backtrace"] }
+clap = { version = "4.2.4", features = ["derive"] }