summaryrefslogtreecommitdiff
path: root/candle-core/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'candle-core/Cargo.toml')
-rw-r--r--candle-core/Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/candle-core/Cargo.toml b/candle-core/Cargo.toml
index 8ea2b08c..4ffc869f 100644
--- a/candle-core/Cargo.toml
+++ b/candle-core/Cargo.toml
@@ -30,6 +30,7 @@ safetensors = { workspace = true }
thiserror = { workspace = true }
ug = { workspace = true }
ug-cuda = { workspace = true, optional = true }
+ug-metal = { workspace = true, optional = true }
yoke = { workspace = true }
zip = { workspace = true }
@@ -45,7 +46,7 @@ cuda = ["cudarc", "dep:candle-kernels", "dep:ug-cuda"]
cudnn = ["cuda", "cudarc/cudnn"]
mkl = ["dep:libc", "dep:intel-mkl-src"]
accelerate = ["dep:libc", "dep:accelerate-src"]
-metal = ["dep:metal", "dep:candle-metal-kernels"]
+metal = ["dep:metal", "dep:candle-metal-kernels", "dep:ug-metal"]
[[bench]]
name = "bench_main"