summaryrefslogtreecommitdiff
path: root/candle-flash-attn/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'candle-flash-attn/Cargo.toml')
-rw-r--r--candle-flash-attn/Cargo.toml18
1 files changed, 18 insertions, 0 deletions
diff --git a/candle-flash-attn/Cargo.toml b/candle-flash-attn/Cargo.toml
new file mode 100644
index 00000000..25201a0e
--- /dev/null
+++ b/candle-flash-attn/Cargo.toml
@@ -0,0 +1,18 @@
+[package]
+name = "candle-flash-attn"
+version = "0.1.0"
+edition = "2021"
+
+description = "Flash attention layer for the candle ML framework."
+repository = "https://github.com/LaurentMazare/candle"
+keywords = ["blas", "tensor", "machine-learning"]
+categories = ["science"]
+license = "MIT/Apache-2.0"
+readme = "README.md"
+
+[dependencies]
+candle = { path = "../candle-core", features = ["cuda"] }
+half = { version = "2.3.1", features = ["num-traits"] }
+
+[build-dependencies]
+anyhow = { version = "1", features = ["backtrace"] }