summaryrefslogtreecommitdiff
path: root/candle-nn/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'candle-nn/Cargo.toml')
-rw-r--r--candle-nn/Cargo.toml5
1 files changed, 5 insertions, 0 deletions
diff --git a/candle-nn/Cargo.toml b/candle-nn/Cargo.toml
index 3408dae3..9f0d56bd 100644
--- a/candle-nn/Cargo.toml
+++ b/candle-nn/Cargo.toml
@@ -26,6 +26,7 @@ candle-metal-kernels = { workspace = true, optional = true }
anyhow = { workspace = true }
clap = { workspace = true }
rand = { workspace = true }
+criterion = { workspace = true }
[features]
default = []
@@ -33,3 +34,7 @@ accelerate = ["dep:accelerate-src", "candle/accelerate"]
cuda = ["candle/cuda"]
mkl = ["dep:intel-mkl-src", "candle/mkl"]
metal = ["candle/metal", "dep:candle-metal-kernels", "dep:metal"]
+
+[[bench]]
+name = "bench_main"
+harness = false \ No newline at end of file