summaryrefslogtreecommitdiff
path: root/candle-pyo3/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'candle-pyo3/Cargo.toml')
-rw-r--r--candle-pyo3/Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/candle-pyo3/Cargo.toml b/candle-pyo3/Cargo.toml
index 8bccbcc6..0241d2b2 100644
--- a/candle-pyo3/Cargo.toml
+++ b/candle-pyo3/Cargo.toml
@@ -14,16 +14,18 @@ name = "candle"
crate-type = ["cdylib"]
[dependencies]
+accelerate-src = { workspace = true, optional = true }
candle = { path = "../candle-core", version = "0.3.0", package = "candle-core" }
candle-nn = { path = "../candle-nn", version = "0.3.0" }
half = { workspace = true }
-pyo3 = { version = "0.19.0", features = ["extension-module"] }
intel-mkl-src = { workspace = true, optional = true }
+pyo3 = { version = "0.19.0", features = ["extension-module"] }
[build-dependencies]
pyo3-build-config = "0.19"
[features]
default = []
+accelerate = ["dep:accelerate-src", "candle/accelerate"]
cuda = ["candle/cuda"]
mkl = ["dep:intel-mkl-src","candle/mkl"]