summaryrefslogtreecommitdiff
path: root/candle-pyo3/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'candle-pyo3/pyproject.toml')
-rw-r--r--candle-pyo3/pyproject.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/candle-pyo3/pyproject.toml b/candle-pyo3/pyproject.toml
index 88793493..e375796c 100644
--- a/candle-pyo3/pyproject.toml
+++ b/candle-pyo3/pyproject.toml
@@ -28,3 +28,7 @@ features = ["pyo3/extension-module"]
[tool.black]
line-length = 119
target-version = ['py35']
+
+[project.optional-dependencies]
+testing = ["pytest", "black==22.3"]
+huggingface = ["transformers>=4.33.3", "huggingface-hub>=0.17.3"] \ No newline at end of file