summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2022-01-04 17:51:05 +0800
committerPo Lu <luangruo@yahoo.com>2022-01-04 17:51:05 +0800
commit3e247bd34c9dcd6300140efe4534b1f3a7bdc776 (patch)
treeefdb340dd57f2dcbe8feb9e8468b08bc3da122e2 /configure.ac
parent61b57ec6de41a0b63083b4c95a13b0e18e70ce90 (diff)
downloademacs-3e247bd34c9dcd6300140efe4534b1f3a7bdc776.tar.gz
emacs-3e247bd34c9dcd6300140efe4534b1f3a7bdc776.tar.bz2
emacs-3e247bd34c9dcd6300140efe4534b1f3a7bdc776.zip
; * configure.ac: Move some AC_SUBSTs to the correct location.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 517a5b5ba5e..baf8c8018ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2280,6 +2280,7 @@ term_header=
HAVE_X_WINDOWS=no
HAVE_X11=no
USE_X_TOOLKIT=none
+HAVE_PGTK=no
case "${window_system}" in
x11 )
@@ -2318,12 +2319,12 @@ dnl use the toolkit if we have gtk, or X11R5 or newer.
USE_X_TOOLKIT=none
HAVE_PGTK=yes
AC_DEFINE([HAVE_PGTK], 1, [Define to 1 if you have pure Gtk+-3.])
- AC_SUBST(HAVE_PGTK)
;;
haiku )
term_header=haikuterm.h
;;
esac
+AC_SUBST(HAVE_PGTK)
if test "$window_system" = none && test "X$with_x" != "Xno"; then
AC_CHECK_PROG(HAVE_XSERVER, X, true, false)
@@ -3009,7 +3010,6 @@ if test "${HAVE_X11}" = "yes" -o "${window_system}" = "pgtk" && test "${with_gse
if test "$emacs_cv_gsettings_in_gio" = "yes"; then
AC_DEFINE(HAVE_GSETTINGS, 1, [Define to 1 if using GSettings.])
- AC_SUBST(HAVE_GSETTINGS)
SETTINGS_CFLAGS="$GSETTINGS_CFLAGS"
SETTINGS_LIBS="$GSETTINGS_LIBS"
test "$with_gconf" = "yes" || with_gconf=no
@@ -3018,6 +3018,7 @@ if test "${HAVE_X11}" = "yes" -o "${window_system}" = "pgtk" && test "${with_gse
LIBS=$old_LIBS
fi
fi
+AC_SUBST(HAVE_GSETTINGS)
dnl GConf has been tested under GNU/Linux only.
dnl The version is really arbitrary, it is about the same age as Gtk+ 2.6.