summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-01-31 08:49:36 +0100
committerUlrich Müller <ulm@gentoo.org>2024-02-01 13:29:55 +0100
commit5f3b46c61e23786295e8e532f7eadeee8cd4340b (patch)
tree9705a5ea32d47363be322c5f20668fc3e8fb7387 /configure.ac
parent5ce02c91bc128f390bcf0beb82e37a3fa7f251ba (diff)
downloademacs-5f3b46c61e23786295e8e532f7eadeee8cd4340b.tar.gz
emacs-5f3b46c61e23786295e8e532f7eadeee8cd4340b.tar.bz2
emacs-5f3b46c61e23786295e8e532f7eadeee8cd4340b.zip
* configure.ac: Include X11/Xlib.h for XOpenDisplay. (Bug#68842)
Do not merge to master.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 78d5475f75a..34a5a89bea9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2697,7 +2697,7 @@ if test "${HAVE_X11}" = "yes"; then
if test "${opsys}" = "gnu-linux"; then
AC_CACHE_CHECK([whether X on GNU/Linux needs -b to link], [emacs_cv_b_link],
- [AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+ [AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <X11/Xlib.h>]],
[[XOpenDisplay ("foo");]])],
[xgnu_linux_first_failure=no],
[xgnu_linux_first_failure=yes])
@@ -2706,7 +2706,7 @@ if test "${HAVE_X11}" = "yes"; then
OLD_LIBS="$LIBS"
CPPFLAGS="$CPPFLAGS -b i486-linuxaout"
LIBS="$LIBS -b i486-linuxaout"
- AC_LINK_IFELSE([AC_LANG_PROGRAM([[]],
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#include <X11/Xlib.h>]],
[[XOpenDisplay ("foo");]])],
[xgnu_linux_second_failure=no],
[xgnu_linux_second_failure=yes])