summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Martín <mardani29@yahoo.es>2022-08-27 15:28:34 +0200
committerLars Ingebrigtsen <larsi@gnus.org>2022-08-27 15:29:11 +0200
commit716441a069541ad4efe5eca773e2a41f04f540d1 (patch)
tree284544a8750872a3179da56492b5960f13eba8af /configure.ac
parenta2d62456a7b8da27fb9b64f71b6ce588f2d73287 (diff)
downloademacs-716441a069541ad4efe5eca773e2a41f04f540d1.tar.gz
emacs-716441a069541ad4efe5eca773e2a41f04f540d1.tar.bz2
emacs-716441a069541ad4efe5eca773e2a41f04f540d1.zip
Fix webp detection on some Macos systems
* configure.ac (HAVE_RSVG): Make webp detection work with Macos 10.3/Homebrew (bug#57420).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6ca3052ea3a..4590ed3506e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2773,12 +2773,9 @@ if test "${with_webp}" != "no"; then
|| test "${HAVE_W32}" = "yes" || test "${HAVE_NS}" = "yes" \
|| test "${HAVE_BE_APP}" = "yes" || test "${HAVE_PGTK}" = "yes"; then
WEBP_REQUIRED=0.6.0
- WEBP_MODULE="libwebp >= $WEBP_REQUIRED"
+ WEBP_MODULE="libwebpdemux >= $WEBP_REQUIRED"
EMACS_CHECK_MODULES([WEBP], [$WEBP_MODULE])
- if test "$HAVE_WEBP" = "yes"; then
- WEBP_LIBS="-lwebp -lwebpdemux"
- fi
AC_SUBST([WEBP_CFLAGS])
AC_SUBST([WEBP_LIBS])
fi