summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2022-08-04 15:37:54 +0800
committerPo Lu <luangruo@yahoo.com>2022-08-04 15:38:23 +0800
commit78129dcf53ab2b1ce49eab28dba89dea9f687284 (patch)
tree78e86ecfacea3de899bd0958225f2c4c097cda84 /configure.ac
parent3e60f7f3c31a8491b085684121e5229be56b3538 (diff)
downloademacs-78129dcf53ab2b1ce49eab28dba89dea9f687284.tar.gz
emacs-78129dcf53ab2b1ce49eab28dba89dea9f687284.tar.bz2
emacs-78129dcf53ab2b1ce49eab28dba89dea9f687284.zip
Correctly implement refresh synchronization fences
* configure.ac (HAVE_XSYNC): Also check for XSyncTriggerFence. * src/xfns.c (Fx_create_frame): Create fences. * src/xterm.c (x_atom_refs): New atom. (x_sync_trigger_fence, x_sync_init_fences, x_sync_free_fences): New functions. (x_sync_update_finish): Trigger the appropriate fence. (x_free_frame_resources): Free fences. * src/xterm.h (struct x_display_info): New atom `_NET_WM_SYNC_FENCES'. (struct x_output): New field `sync_fences'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 87c126ecbbf..1a264275bd4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4675,6 +4675,10 @@ if test "${HAVE_X11}" = "yes"; then
AC_DEFINE([HAVE_XSYNC], [1],
[Define to 1 if the X Synchronization Extension is available.])
XSYNC_LIBS="-lXext"
+ OLDLIBS="$LIBS"
+ LIBS="-lXext $LIBS" # Set this temporarily for AC_CHECK_FUNC
+ AC_CHECK_FUNCS([XSyncTriggerFence]) # Check for version 3.1
+ LIBS="$OLDLIBS"
fi
fi
AC_SUBST([XSYNC_LIBS])