summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYuan Fu <casouri@gmail.com>2022-10-05 14:22:03 -0700
committerYuan Fu <casouri@gmail.com>2022-10-05 14:22:03 -0700
commit7ebbd4efc3d45403cf845d35c36c21756baeeba8 (patch)
treef53223ce7dbd64c079aced6e1a77964d1a8eaa3f /configure.ac
parentcb183f6467401fb5ed2b7fc98ca75be9d943cbe3 (diff)
parent95efafb72664049f8ac825047df3645656cf76f4 (diff)
downloademacs-7ebbd4efc3d45403cf845d35c36c21756baeeba8.tar.gz
emacs-7ebbd4efc3d45403cf845d35c36c21756baeeba8.tar.bz2
emacs-7ebbd4efc3d45403cf845d35c36c21756baeeba8.zip
Merge branch 'master' into feature/tree-sitter
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 23 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 43827e07a5f..7d751fd6a81 100644
--- a/configure.ac
+++ b/configure.ac
@@ -495,7 +495,6 @@ OPTION_DEFAULT_ON([gnutls],[don't use -lgnutls for SSL/TLS support])
OPTION_DEFAULT_ON([zlib],[don't compile with zlib decompression support])
OPTION_DEFAULT_ON([modules],[don't compile with dynamic modules support])
OPTION_DEFAULT_ON([threads],[don't compile with elisp threading support])
-OPTION_DEFAULT_OFF([native-compilation],[compile with Emacs Lisp native compiler support])
OPTION_DEFAULT_OFF([cygwin32-native-compilation],[use native compilation on 32-bit Cygwin])
OPTION_DEFAULT_ON([xinput2],[don't use version 2 of the X Input Extension for input])
OPTION_DEFAULT_OFF([small-ja-dic],[generate a smaller-size Japanese dictionary])
@@ -1010,6 +1009,29 @@ AC_ARG_ENABLE([gcc-warnings],
[gl_GCC_VERSION_IFELSE([5], [3], [gl_gcc_warnings=warn-only])])
fi])
+NATIVE_COMPILATION_AOT=no
+AC_ARG_WITH([native-compilation],
+ [AS_HELP_STRING([--with-native-compilation@<:@=TYPE@:>@],
+ [compile with Emacs Lisp native compiler support. The TYPE
+ 'yes' (or empty) means to enable it and compile natively
+ preloaded Lisp files; 'no' means to disable it;
+ 'aot' will make the build process compile all the Lisp
+ files in the tree natively ahead of time. (This will
+ usually be quite slow.)])],
+ [
+ case $withval in
+ aot)
+ withval=yes
+ NATIVE_COMPILATION_AOT=yes
+ ;;
+ yes|no) ;;
+ *) AC_MSG_ERROR([bad value $withval for native-compilation option]) ;;
+ esac
+ with_native_compilation=$withval],
+ [with_native_compilation=no]
+)
+AC_SUBST([NATIVE_COMPILATION_AOT])
+
AC_ARG_ENABLE([check-lisp-object-type],
[AS_HELP_STRING([--enable-check-lisp-object-type],
[Enable compile time checks for the Lisp_Object data type,