summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPaul Eggert <eggert@cs.ucla.edu>2022-02-23 10:52:27 -0800
committerPaul Eggert <eggert@cs.ucla.edu>2022-02-23 11:41:01 -0800
commit995aed477dc9be708920cc46442673126ed75760 (patch)
treed11e7df1695cc0e931da6c6d9779cbe4c0970b88 /configure.ac
parent435d5c84ed200b24b0cd5b51fa77026e861eff3f (diff)
downloademacs-995aed477dc9be708920cc46442673126ed75760.tar.gz
emacs-995aed477dc9be708920cc46442673126ed75760.tar.bz2
emacs-995aed477dc9be708920cc46442673126ed75760.zip
Port to current Gnulib
* configure.ac (AM_COND_IF): New macro, needed because Gnulib normally assumes Automake and now uses this Automake macro. Problem reported by Lars Ingebrigtsen (Bug#32452#47).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 00711cccd5d..a315eeb6bd2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1201,6 +1201,8 @@ dnl Automake replacements.
AC_DEFUN([AM_CONDITIONAL],
[$2 && $1_CONDITION=1 || $1_CONDITION=
AC_SUBST([$1_CONDITION])])
+AC_DEFUN([AM_COND_IF],
+ [AS_IF([test "$$1_CONDITION"], [$2], [$3])])
dnl Prefer silent make output. For verbose output, use
dnl 'configure --disable-silent-rules' or 'make V=1' .