summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPo Lu <luangruo@yahoo.com>2022-02-04 03:28:05 +0000
committerPo Lu <luangruo@yahoo.com>2022-02-04 03:28:05 +0000
commita654985bca4c48472bd17a2723fc93bcd5e27d6c (patch)
treea8b78981b1db2277d5b8c36eb97c30994c6b80eb /configure.ac
parent52c4275283b342d3792d3eb4d4be44cb567b2bc7 (diff)
downloademacs-a654985bca4c48472bd17a2723fc93bcd5e27d6c.tar.gz
emacs-a654985bca4c48472bd17a2723fc93bcd5e27d6c.tar.bz2
emacs-a654985bca4c48472bd17a2723fc93bcd5e27d6c.zip
Make Emacs build with some other XLib implementations
* configure.ac (HAVE_XKB): Check for functions that aren't always implemented by various XLib implementations. * src/xfns.c (select_visual): Handle NULL values of vinfo. (XkbRefreshKeyboardMapping): (XkbFreeNames): (XDisplayCells): (XDestroySubwindows): Define replacement functions where they aren't available. * src/xterm.c (x_find_modifier_meanings): Handle NULL values of various fields.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9f4d5db43f1..2ad5f2312c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2620,10 +2620,11 @@ if test "${HAVE_X11}" = "yes"; then
emacs_cv_xkb=yes, emacs_cv_xkb=no)])
if test $emacs_cv_xkb = yes; then
AC_DEFINE(HAVE_XKB, 1, [Define to 1 if you have the Xkb extension.])
+ AC_CHECK_FUNCS(XkbRefreshKeyboardMapping XkbFreeNames)
fi
- AC_CHECK_FUNCS(XrmSetDatabase XScreenResourceString \
-XScreenNumberOfScreen)
+ AC_CHECK_FUNCS(XrmSetDatabase XScreenResourceString XScreenNumberOfScreen)
+ AC_CHECK_FUNCS(XDisplayCells XDestroySubwindows)
fi
if test "${window_system}" = "x11"; then