summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorGlenn Morris <rgm@gnu.org>2012-06-12 15:15:47 -0400
committerGlenn Morris <rgm@gnu.org>2012-06-12 15:15:47 -0400
commit1cce69208a638b9ce789e4c21df55b2315efd97c (patch)
tree5d5fea43b2c36db2f3293d5ee386afd676ba270c /configure.in
parentb4492cba7a034185fecea38790b58c20667bfee0 (diff)
downloademacs-1cce69208a638b9ce789e4c21df55b2315efd97c.tar.gz
emacs-1cce69208a638b9ce789e4c21df55b2315efd97c.tar.bz2
emacs-1cce69208a638b9ce789e4c21df55b2315efd97c.zip
Combine adjacent case blocks.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in43
1 files changed, 21 insertions, 22 deletions
diff --git a/configure.in b/configure.in
index 1f18937dbd9..6c5ba7a06b9 100644
--- a/configure.in
+++ b/configure.in
@@ -3133,29 +3133,28 @@ case $opsys in
esac
case $opsys in
- hpux11)
- dnl SA_RESTART resets the timeout of `select', so don't use it.
- AC_DEFINE(BROKEN_SA_RESTART, 1, [Define if SA_RESTART should not
- be used.])
- dnl It works to open the pty's tty in the parent (Emacs), then
- dnl close and reopen it in the child.
- AC_DEFINE(USG_SUBTTY_WORKS, 1, [Define for USG systems where it
- works to open a pty's tty in the parent process, then close and
- reopen it in the child.])
-
- opsysfile="s/hpux10-20.h"
- ;;
-
- sol2-10)
- AC_DEFINE(_STRUCTURED_PROC, 1, [Needed for system_process_attributes
- on Solaris.])
- opsysfile="s/sol2-6.h"
- ;;
-esac
+ gnu-kfreebsd) opsysfile="s/gnu-linux.h" ;;
+
+ hpux11)
+ dnl SA_RESTART resets the timeout of `select', so don't use it.
+ AC_DEFINE(BROKEN_SA_RESTART, 1, [Define if SA_RESTART should not
+ be used.])
+ dnl It works to open the pty's tty in the parent (Emacs), then
+ dnl close and reopen it in the child.
+ AC_DEFINE(USG_SUBTTY_WORKS, 1, [Define for USG systems where it
+ works to open a pty's tty in the parent process, then close and
+ reopen it in the child.])
+
+ opsysfile="s/hpux10-20.h"
+ ;;
-case $opsys in
- gnu-kfreebsd) opsysfile="s/gnu-linux.h" ;;
- openbsd) opsysfile="s/netbsd.h" ;;
+ openbsd) opsysfile="s/netbsd.h" ;;
+
+ sol2-10)
+ AC_DEFINE(_STRUCTURED_PROC, 1, [Needed for system_process_attributes
+ on Solaris.])
+ opsysfile="s/sol2-6.h"
+ ;;
esac
# Set up the CFLAGS for real compilation, so we can substitute it.