summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2004-08-26 19:00:58 -0400
committerJohn Wiegley <johnw@newartisans.com>2004-08-26 19:00:58 -0400
commite12cc11760582707539f9ca3cda21be45f15e604 (patch)
tree63ef937102397681b3d00d65a2ce079b702d846e /configure.ac
parentae37cb8ece28420f1cee885e269ba2999f58140c (diff)
downloadledger-e12cc11760582707539f9ca3cda21be45f15e604.tar.gz
ledger-e12cc11760582707539f9ca3cda21be45f15e604.tar.bz2
ledger-e12cc11760582707539f9ca3cda21be45f15e604.zip
added check for --enable-standalone, as mentioned in the README
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d2430126..4f3492b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,7 @@ AC_CHECK_LIB([xmlparse], [XML_ParserCreate],
# Check for options
AC_ARG_ENABLE(debug,
- [ --enable-debug Turn on debugging],
+ [ --enable-debug Turn on debugging],
[case "${enableval}" in
yes) debug=true ;;
no) debug=false ;;
@@ -35,6 +35,15 @@ AC_ARG_ENABLE(debug,
esac],[debug=false])
AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
+AC_ARG_ENABLE(standalone,
+ [ --enable-standalone Build standalone on OS/X (see README)],
+ [case "${enableval}" in
+ yes) standalone=true ;;
+ no) standalone=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-standalone) ;;
+ esac],[standalone=false])
+AM_CONDITIONAL(STANDALONE, test x$standalone = xtrue)
+
# Checks for header files.
AC_STDC_HEADERS
AC_HAVE_HEADERS(sys/stat.h)