summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Reinking <reinking@google.com>2022-08-25 22:15:18 -0400
committerGitHub <noreply@github.com>2022-08-25 19:15:18 -0700
commit0b83fe4b05f4c814ae5be3e1d03068918d9ecd7e (patch)
tree8ceb0e86b2a64c8c5f4ab48a43304fd78be83bfb /CMakeLists.txt
parent5abf3c27bb0c1ea2bcfcfe18225e7c453d3e7c1c (diff)
downloadwabt-0b83fe4b05f4c814ae5be3e1d03068918d9ecd7e.tar.gz
wabt-0b83fe4b05f4c814ae5be3e1d03068918d9ecd7e.tar.bz2
wabt-0b83fe4b05f4c814ae5be3e1d03068918d9ecd7e.zip
Fix test dependencies (#1970)
* Only search for Python when BUILD_TESTS=ON Rather than disable tests with a warning when Python cannot be found, require it when tests are enabled. Avoid the search altogether when tests are disabled. This check additionally causes issues with FetchContent users that use the newer FindPython(3) module. Fixes #1385 * Fix usage of Threads find_package(Threads) was called redundantly and a bad check was used to disable a pthreads-specific test. Rather than checking WIN32, one should check CMAKE_USE_PTHREADS_INIT
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt19
1 files changed, 7 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7cc8e59..a4e8e7e3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -570,15 +570,13 @@ if (BUILD_TOOLS)
endif ()
endif ()
-# Python 3.5 is the version shipped in Ubuntu Xenial
-find_package(PythonInterp 3.5)
-if(BUILD_TESTS AND (NOT PYTHONINTERP_FOUND))
- set(BUILD_TESTS OFF)
- message(WARNING "Skipping tests. Python 3 is required for wabt testing. Please install python3 to run tests.")
-endif()
-
-find_package(Threads)
if (BUILD_TESTS)
+ set(THREADS_PREFER_PTHREAD_FLAG ON)
+ find_package(Threads REQUIRED)
+
+ # Python 3.5 is the version shipped in Ubuntu Xenial
+ find_package(PythonInterp 3.5 REQUIRED)
+
if (NOT USE_SYSTEM_GTEST)
if (NOT EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/third_party/gtest/googletest)
message(FATAL_ERROR "Can't find third_party/gtest. Run git submodule update --init, or disable with CMake -DBUILD_TESTS=OFF.")
@@ -685,10 +683,7 @@ if (BUILD_TESTS)
c_api_example(start)
c_api_example(table)
c_api_example(trap)
- if (NOT WIN32)
- # depends on pthreads
- set(THREADS_PREFER_PTHREAD_FLAG ON)
- find_package(Threads REQUIRED)
+ if (CMAKE_USE_PTHREADS_INIT)
c_api_example(threads)
endif ()
endif ()