summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRaphael Graf <r@undefined.ch>2020-03-15 18:12:05 +0100
committerGitHub <noreply@github.com>2020-03-15 10:12:05 -0700
commit261dfdd75d8199298c9e0143e351322cc79c996a (patch)
treeb4f6ab2a0a80b571dce337707ae932e92b537f56 /CMakeLists.txt
parenta5994b2f94586063f7cce021e537f2cda82f3ba0 (diff)
downloadwabt-261dfdd75d8199298c9e0143e351322cc79c996a.tar.gz
wabt-261dfdd75d8199298c9e0143e351322cc79c996a.tar.bz2
wabt-261dfdd75d8199298c9e0143e351322cc79c996a.zip
Set -D_POSIX_C_SOURCE for MINGW/CYGWIN only (#1360)
Resolves #1359
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 5 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 958ee8b3..6f869bff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,9 +133,11 @@ else ()
# definition, and some libcs (e.g. glibc2.17 and earlier) follow that.
add_definitions(-D__STDC_LIMIT_MACROS=1 -D__STDC_FORMAT_MACROS=1)
- # On MINGW, _POSIX_C_SOURCE is needed to ensure we use mingw printf
- # instead of the VC runtime one.
- add_definitions(-D_POSIX_C_SOURCE=200809L)
+ if (MINGW OR CYGWIN)
+ # On MINGW, _POSIX_C_SOURCE is needed to ensure we use mingw printf
+ # instead of the VC runtime one.
+ add_definitions(-D_POSIX_C_SOURCE=200809L)
+ endif()
if (COMPILER_IS_GNU)
# disable -Wclobbered: it seems to be guessing incorrectly about a local