summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSoni L <EnderMoneyMod@gmail.com>2020-12-07 16:18:58 -0300
committerGitHub <noreply@github.com>2020-12-07 11:18:58 -0800
commit3c4bad02b95e8ef6b4f773647adcbe467cc316f3 (patch)
tree5338444436b04ee3de09419e6bf2dd0932b6c16c /CMakeLists.txt
parent60dee30f5711f82a019f462144d7ff4d42c6a259 (diff)
downloadwabt-3c4bad02b95e8ef6b4f773647adcbe467cc316f3.tar.gz
wabt-3c4bad02b95e8ef6b4f773647adcbe467cc316f3.tar.bz2
wabt-3c4bad02b95e8ef6b4f773647adcbe467cc316f3.zip
Port to big-endian platforms (s390x but others can be trivially added) (#1557)
* Initial attempt at s390x port * Second attempt at s390x port * Fix big-endian memory fill * Fix more memory location calculations * Improve SIMD * Implement big-endian memory grow * Fill relocation with 0x00, as per spec * Make wasm2c endianness work * Fix shuffle * Fix load endianness in wasm2c * Refactor into shared code * Clean up SwapBytesSized * Clean up MemcpyEndianAware * Clean up * "Fix" opcodecnt basic test
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fba3fd93..0e6ffb36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,6 +191,8 @@ else ()
set(TARGET_ARCH "i386")
elseif (${FILE_OUTPUT} MATCHES "ARM")
set(TARGET_ARCH "ARM")
+ elseif (${FILE_OUTPUT} MATCHES "IBM S/390")
+ set(TARGET_ARCH "s390x")
else ()
message(WARNING "Unknown target architecture!")
endif ()
@@ -205,6 +207,9 @@ else ()
# wasm doesn't allow for x87 floating point math
add_definitions(-msse2 -mfpmath=sse)
endif ()
+ if (TARGET_ARCH STREQUAL "s390x")
+ add_definitions(-DWABT_BIG_ENDIAN=1)
+ endif ()
endif ()
endif ()