summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Winstein <keithw@cs.stanford.edu>2022-07-11 15:37:40 -0700
committerGitHub <noreply@github.com>2022-07-11 22:37:40 +0000
commit4132e35b51849678ac9e5592089e00057f260ccf (patch)
tree97b6021a35874629bf6701e34e29474af04ec48d /CMakeLists.txt
parent2106ff48b285f28581c2598222d61636f3469a1c (diff)
downloadwabt-4132e35b51849678ac9e5592089e00057f260ccf.tar.gz
wabt-4132e35b51849678ac9e5592089e00057f260ccf.tar.bz2
wabt-4132e35b51849678ac9e5592089e00057f260ccf.zip
wasm2c: simplify handling of templated code (#1940)
Store templated wasm2c code as .h/.c; build templates on demand
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1fe79b8d..dac8511e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -468,9 +468,29 @@ if (BUILD_TOOLS)
)
# wasm2c
+ set(TEMPLATE_CMAKE ${WABT_SOURCE_DIR}/scripts/gen-wasm2c-templates.cmake)
+
+ # wasm2c generated code templates
+ add_custom_command(
+ OUTPUT wasm2c_header_top.cc wasm2c_header_bottom.cc wasm2c_source_includes.cc wasm2c_source_declarations.cc
+
+ COMMAND ${CMAKE_COMMAND} -D out="wasm2c_header_top.cc" -D in="${WABT_SOURCE_DIR}/src/template/wasm2c.top.h" -D symbol="s_header_top" -P ${TEMPLATE_CMAKE}
+ COMMAND ${CMAKE_COMMAND} -D out="wasm2c_header_bottom.cc" -D in="${WABT_SOURCE_DIR}/src/template/wasm2c.bottom.h" -D symbol="s_header_bottom" -P ${TEMPLATE_CMAKE}
+ COMMAND ${CMAKE_COMMAND} -D out="wasm2c_source_includes.cc" -D in="${WABT_SOURCE_DIR}/src/template/wasm2c.includes.c" -D symbol="s_source_includes" -P ${TEMPLATE_CMAKE}
+ COMMAND ${CMAKE_COMMAND} -D out="wasm2c_source_declarations.cc" -D in="${WABT_SOURCE_DIR}/src/template/wasm2c.declarations.c" -D symbol="s_source_declarations" -P ${TEMPLATE_CMAKE}
+
+ DEPENDS ${WABT_SOURCE_DIR}/src/template/wasm2c.top.h
+ ${WABT_SOURCE_DIR}/src/template/wasm2c.bottom.h
+ ${WABT_SOURCE_DIR}/src/template/wasm2c.includes.c
+ ${WABT_SOURCE_DIR}/src/template/wasm2c.declarations.c
+ )
+
+ add_library(cwriter-template wasm2c_header_top.cc wasm2c_header_bottom.cc wasm2c_source_includes.cc wasm2c_source_declarations.cc)
+
wabt_executable(
NAME wasm2c
SOURCES src/tools/wasm2c.cc src/c-writer.cc
+ LIBS cwriter-template
INSTALL
)