summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorokuoku <mjt@cltn.org>2020-02-19 04:15:32 +0900
committerGitHub <noreply@github.com>2020-02-18 11:15:32 -0800
commit4c3189d1df4a4062fb2705182a525fd8c23d6af2 (patch)
treecb9972e4bc07c56c0d45ee6fa16a3027859a165b /CMakeLists.txt
parent4ba97c116d1417b2fb516299a37965820b93ced3 (diff)
downloadwabt-4c3189d1df4a4062fb2705182a525fd8c23d6af2.tar.gz
wabt-4c3189d1df4a4062fb2705182a525fd8c23d6af2.tar.bz2
wabt-4c3189d1df4a4062fb2705182a525fd8c23d6af2.zip
Use standard C++11 on GNU/Clang compilers (#1333)
* Use _POSIX_C_SOURCE where applicable Use _POSIX_C_SOURCE=200809L everywhere except MSVC. For MinGW, it should have same effect in regard of `__USE_MINGW_ANSI_STDIO`. For Cygwin, it will allow to use POSIX APIs under `-std=c++11` environment. * binary-reader-objdump.cc: #include <strings.h> Include `strings.h` because it depends POSIX strcasecmp. * Disable `CMAKE_CXX_EXTENSIONS` explicitly Explicitly disable `CMAKE_CXX_EXTENSIONS` which is ON by default in recent CMake(>= 3.1) which will read implicit `-std=gnu++11` injection. * test-hexfloat: Use <thread> instead of sysconf Use <thread> instead of sysconf which is a bit more "standard" way to do this. * Guard <strings.h> with HAVE_STRCASECMP Guard `strings.h` with `HAVE_STRCASECMP` because non-POSIX platform may not have it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt20
1 files changed, 5 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 638d2511..a7d30ac1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,7 +75,6 @@ include(CheckSymbolExists)
check_include_file("alloca.h" HAVE_ALLOCA_H)
check_include_file("unistd.h" HAVE_UNISTD_H)
check_symbol_exists(snprintf "stdio.h" HAVE_SNPRINTF)
-check_symbol_exists(sysconf "unistd.h" HAVE_SYSCONF)
check_symbol_exists(strcasecmp "strings.h" HAVE_STRCASECMP)
if (WIN32)
@@ -118,15 +117,8 @@ else ()
-Wuninitialized
)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wold-style-cast")
-
- if(NOT CYGWIN)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
- else()
- # On Cygwin, POSIX extensions are not visible with std=c++11
- # because it defines __STRICT_ANSI__.
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++11")
- endif()
+ set(CMAKE_CXX_EXTENSIONS OFF)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11 -Wold-style-cast")
if (WERROR)
add_definitions(-Werror)
@@ -141,11 +133,9 @@ else ()
# definition, and some libcs (e.g. glibc2.17 and earlier) follow that.
add_definitions(-D__STDC_LIMIT_MACROS=1 -D__STDC_FORMAT_MACROS=1)
- if (MINGW)
- # _POSIX is needed to ensure we use mingw printf
- # instead of the VC runtime one.
- add_definitions(-D_POSIX)
- endif ()
+ # On MINGW, _POSIX_C_SOURCE is needed to ensure we use mingw printf
+ # instead of the VC runtime one.
+ add_definitions(-D_POSIX_C_SOURCE=200809L)
if (COMPILER_IS_GNU)
# disable -Wclobbered: it seems to be guessing incorrectly about a local