summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Clegg <sbc@chromium.org>2023-02-26 17:39:17 -0800
committerGitHub <noreply@github.com>2023-02-27 01:39:17 +0000
commit546d42a6ce52e67270ed7957b249bc59b4b57a1b (patch)
treeb327c19a95710df8be60716220d6630bf01b7b47 /CMakeLists.txt
parent3d9ec159cb362d71cf76938d583841975b3e730a (diff)
downloadwabt-546d42a6ce52e67270ed7957b249bc59b4b57a1b.tar.gz
wabt-546d42a6ce52e67270ed7957b249bc59b4b57a1b.tar.bz2
wabt-546d42a6ce52e67270ed7957b249bc59b4b57a1b.zip
Use C++17's [[fallthrough]]. NFC (#2091)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48812d13..2bfe62a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,7 +164,7 @@ else ()
# interfaces, etc.
# disable -Wpointer-arith: this is a GCC extension, and doesn't work in MSVC.
add_definitions(
- -Wall -Wextra -Wno-unused-parameter -Wpointer-arith -Wuninitialized
+ -Wall -Wextra -Wno-unused-parameter -Wpointer-arith -Wuninitialized -Wimplicit-fallthrough
)
set(CMAKE_CXX_EXTENSIONS OFF)
@@ -563,7 +563,9 @@ if (BUILD_TOOLS)
if (COMPILER_IS_GNU)
target_compile_options(uv_a PRIVATE "-Wno-sign-compare")
- endif ()
+ elseif (COMPILER_IS_CLANG)
+ target_compile_options(uv_a PRIVATE "-Wno-implicit-fallthrough")
+ endif()
endif()
# wasm-interp