summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKeith Winstein <keithw@cs.stanford.edu>2022-11-30 12:50:19 -0800
committerGitHub <noreply@github.com>2022-11-30 12:50:19 -0800
commit5a20630f4ea69c1aa215996b4a14e69865fe6de9 (patch)
tree95a1b8ad733f27e6ef7a1bf65119f437eae0eea9 /CMakeLists.txt
parent46e7bc54aacdbe504d9fbb5272cbfb5e39fb11ae (diff)
downloadwabt-5a20630f4ea69c1aa215996b4a14e69865fe6de9.tar.gz
wabt-5a20630f4ea69c1aa215996b4a14e69865fe6de9.tar.bz2
wabt-5a20630f4ea69c1aa215996b4a14e69865fe6de9.zip
Silence gtest and uvwasi warnings on GCC 11 (#2082)
Required to pass CI on ubuntu-22.04 runners which are phasing in for "ubuntu-latest" workflows on GitHub.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 12ba93d9..d374b54b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -534,6 +534,10 @@ if (BUILD_TOOLS)
add_definitions(-DWITH_WASI)
set(INTERP_LIBS uvwasi_a)
set(EXTRA_INTERP_SRC src/interp/interp-wasi.cc)
+
+ if (COMPILER_IS_GNU)
+ target_compile_options(uv_a PRIVATE "-Wno-sign-compare")
+ endif ()
endif()
# wasm-interp
@@ -618,6 +622,10 @@ if (BUILD_TESTS)
add_library(gtest_main STATIC
third_party/gtest/googletest/src/gtest_main.cc
)
+
+ if (COMPILER_IS_GNU)
+ target_compile_options(gtest PRIVATE "-Wno-maybe-uninitialized")
+ endif ()
endif ()
# hexfloat-test