summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Clegg <sbc@chromium.org>2022-10-04 13:45:01 -0700
committerGitHub <noreply@github.com>2022-10-04 20:45:01 +0000
commit5ff1faaadf177c578e8c1a7949bae092c100eb84 (patch)
tree188c6fe5bc96f5ac5e63739b1afd8ed637c0bda5 /CMakeLists.txt
parent1adcc919ec8ab2f82ead28f9da5d5295ce65dd61 (diff)
downloadwabt-5ff1faaadf177c578e8c1a7949bae092c100eb84.tar.gz
wabt-5ff1faaadf177c578e8c1a7949bae092c100eb84.tar.bz2
wabt-5ff1faaadf177c578e8c1a7949bae092c100eb84.zip
wasm2c: Don't create a separate library for cwriter-template. NFC (#2015)
Fixes: #2014
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2935e9e5..02154a86 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -495,14 +495,13 @@ if (BUILD_TOOLS)
${WABT_SOURCE_DIR}/src/template/wasm2c.bottom.h
${WABT_SOURCE_DIR}/src/template/wasm2c.includes.c
${WABT_SOURCE_DIR}/src/template/wasm2c.declarations.c
- )
+ )
- add_library(cwriter-template wasm2c_header_top.cc wasm2c_header_bottom.cc wasm2c_source_includes.cc wasm2c_source_declarations.cc)
+ set(CWRITER_TEMPLATE_SRC wasm2c_header_top.cc wasm2c_header_bottom.cc wasm2c_source_includes.cc wasm2c_source_declarations.cc)
wabt_executable(
NAME wasm2c
- SOURCES src/tools/wasm2c.cc src/c-writer.cc
- LIBS cwriter-template
+ SOURCES src/tools/wasm2c.cc src/c-writer.cc ${CWRITER_TEMPLATE_SRC}
INSTALL
)