summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Smith <binjimin@gmail.com>2017-06-19 11:14:09 -0700
committerGitHub <noreply@github.com>2017-06-19 11:14:09 -0700
commit6e27ec869dd74b2176e4eae2b2479742c8483664 (patch)
tree303bcdcb733ee9e53b96f0991361275180c17efe /CMakeLists.txt
parentc1507f8aafdf6bc7653657e8fc5895bc88777bc5 (diff)
downloadwabt-6e27ec869dd74b2176e4eae2b2479742c8483664.tar.gz
wabt-6e27ec869dd74b2176e4eae2b2479742c8483664.tar.bz2
wabt-6e27ec869dd74b2176e4eae2b2479742c8483664.zip
Check for USES_TERMINAL support in CMakeLists.txt (#511)
Without this you get a weird error on older versions of CMake.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 73e2a653..339f3f6a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -354,6 +354,10 @@ if (NOT EMSCRIPTEN)
target_link_libraries(wabt-unittests libgtest ${CMAKE_THREAD_LIBS_INIT})
endif ()
+ if (NOT CMAKE_VERSION VERSION_LESS "3.2")
+ set(USES_TERMINAL USES_TERMINAL)
+ endif ()
+
# test running
find_package(PythonInterp 2.7 REQUIRED)
set(RUN_TESTS_PY ${WABT_SOURCE_DIR}/test/run-tests.py)
@@ -361,7 +365,7 @@ if (NOT EMSCRIPTEN)
COMMAND ${PYTHON_EXECUTABLE} ${RUN_TESTS_PY} --bindir ${CMAKE_BINARY_DIR}
DEPENDS ${WABT_EXECUTABLES}
WORKING_DIRECTORY ${WABT_SOURCE_DIR}
- USES_TERMINAL
+ ${USES_TERMINAL}
)
# install