summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorXingqang Bai <bxq2011hust@qq.com>2020-10-22 06:32:45 +0800
committerGitHub <noreply@github.com>2020-10-21 15:32:45 -0700
commit807580497711003aaab04c5e383f5118b3133104 (patch)
treeb2f05e88665af6185590fad0dc47ff0647faa92a /CMakeLists.txt
parentbe5e8bf8ec698f9ad3a1b6fbb412680995fe39bf (diff)
downloadwabt-807580497711003aaab04c5e383f5118b3133104.tar.gz
wabt-807580497711003aaab04c5e383f5118b3133104.tar.bz2
wabt-807580497711003aaab04c5e383f5118b3133104.zip
fix compile failed on Ubuntu 18.04 aarch64 cmake3.10.2 (#1559)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fe043b73..b5cd5650 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -52,6 +52,10 @@ if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git)
endif ()
endif ()
+if (NOT "${CMAKE_PROJECT_VERSION}")
+ set(CMAKE_PROJECT_VERSION ${PROJECT_VERSION})
+endif()
+
option(BUILD_TESTS "Build GTest-based tests" ON)
option(USE_SYSTEM_GTEST "Use system GTest, instead of building" OFF)
option(BUILD_TOOLS "Build wabt commandline tools" ON)