summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBen Smith <binji@chromium.org>2020-02-27 11:23:08 -0800
committerGitHub <noreply@github.com>2020-02-27 11:23:08 -0800
commit9719aa5b0cb3ce03696d255423dabb14c2d289c8 (patch)
tree70e1b6552c41dc6bbf52caa574122dac31557291 /CMakeLists.txt
parent981e30acb316da4da1965969283108e52781e695 (diff)
downloadwabt-9719aa5b0cb3ce03696d255423dabb14c2d289c8.tar.gz
wabt-9719aa5b0cb3ce03696d255423dabb14c2d289c8.tar.bz2
wabt-9719aa5b0cb3ce03696d255423dabb14c2d289c8.zip
Share validator between IR + binary-reader-interp (#1346)
The TypeChecker was already shared, but the rest of the other validation logic was duplicated. This change creates a SharedValidator which is used by both the Validator and the BinaryReaderInterp classes. The validator is structured similarly to TypeChecker as a collection of functions. It's assumed that the functions will be called in the same order as sections occur in the binary format. The IR valiator does this too, even though it's possible to validate components out-of-order in that case. This change also splits Module validation and Script validation into two different classes. It should have been written this way in the first place, and it's nice to do as part of this change since the module validator logic is mostly moved into the SharedValidator anyway. Next steps: * Remove all validation from BinaryReader and move it into the SharedValidator. * Move the TypeChecker into the SharedValidator (maybe not necessary) * Ensure that validation occurs before creating IR from binary (use SharedValidator in BinaryReaderIR? or maybe create BinaryReaderValidator passthru that both BinaryReaderIR and BinaryReaderInterp use?) * Rename Validator -> IRValidator, SharedValidator -> Validator
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4f42023a..958ee8b3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -283,6 +283,8 @@ set(WABT_LIBRARY_SRC
src/option-parser.cc
src/resolve-names.h
src/resolve-names.cc
+ src/shared-validator.h
+ src/shared-validator.cc
src/stream.h
src/stream.cc
src/string-view.h