summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNg Zhi An <ngzhian@gmail.com>2021-03-16 20:58:19 -0700
committerGitHub <noreply@github.com>2021-03-16 20:58:19 -0700
commita24ae3eed05f28d91a48dac2591619dd204e4526 (patch)
treed533dd5b51d78eda9c8bfe6bac43a2049f60aac7 /CMakeLists.txt
parent1692d72ff2f9755f1e26753b6465ae777d1b81b0 (diff)
downloadwabt-a24ae3eed05f28d91a48dac2591619dd204e4526.tar.gz
wabt-a24ae3eed05f28d91a48dac2591619dd204e4526.tar.bz2
wabt-a24ae3eed05f28d91a48dac2591619dd204e4526.zip
Fix ubsan compile (#1641)
This happens when both HAS_UBSAN_RECOVER_BARE and HAS_UBSAN_RECOVER_ALL is supported, then we end up setting USE_UBSAN twice, and hit the FATAL_ERROR "Only one sanitizer allowed".
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43ce5168..8c39c28a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -239,7 +239,8 @@ if (USE_UBSAN)
sanitizer(USE_UBSAN "-fsanitize=undefined -fno-sanitize-recover -fsanitize-blacklist=${UBSAN_BLACKLIST}")
endif ()
check_cxx_compiler_flag("-fsanitize=undefined -fno-sanitize-recover=all -Wall -Werror" HAS_UBSAN_RECOVER_ALL)
- if (HAS_UBSAN_RECOVER_ALL)
+ # If we already setup UBSAN recover bare, setting it up again here will be an error.
+ if (NOT USE_SANITIZER AND HAS_UBSAN_RECOVER_ALL)
sanitizer(USE_UBSAN "-fsanitize=undefined -fno-sanitize-recover=all -fsanitize-blacklist=${UBSAN_BLACKLIST}")
endif ()
if (NOT USE_SANITIZER)