summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRemko Tronçon <remko@users.noreply.github.com>2022-11-13 18:19:27 +0100
committerGitHub <noreply@github.com>2022-11-13 17:19:27 +0000
commita3c6ec4364f87f72c58bce85ab0d3bd0289505f0 (patch)
tree489909bf1f342e2ad7781585698090906eee4b3f /CMakeLists.txt
parentf47432a4b68f8bf2f6ef9fc065f80932df432e1d (diff)
downloadwabt-a3c6ec4364f87f72c58bce85ab0d3bd0289505f0.tar.gz
wabt-a3c6ec4364f87f72c58bce85ab0d3bd0289505f0.tar.bz2
wabt-a3c6ec4364f87f72c58bce85ab0d3bd0289505f0.zip
Install wasm2c source files as data (#2058)
Toolchains using wasm2c depend on the wasm-rt files to build the generated programs. Using a binary wasm-rt library is not enough for toolchains that do e.g. cross-compilation, and they need to copy and use the source files instead. Therefore, package these source files as data for toolchains to use. Closes #2057
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 897c780f..98643745 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -393,10 +393,15 @@ IF (NOT WIN32)
INCLUDES DESTINATION "${CMAKE_INSTALL_INCLUDEDIR}"
)
install(
- FILES "wasm2c/wasm-rt-impl.h" "wasm2c/wasm-rt.h"
+ FILES "wasm2c/wasm-rt.h"
TYPE INCLUDE
COMPONENT wabt-development
)
+ install(
+ FILES "wasm2c/wasm-rt-impl.h" "wasm2c/wasm-rt-impl.c"
+ DESTINATION "${CMAKE_INSTALL_DATADIR}/wabt/wasm2c"
+ COMPONENT wabt-development
+ )
endif ()
endif ()