summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChangqing Jing <changqing.jing@bmw.com>2024-01-20 13:30:47 +0800
committerGitHub <noreply@github.com>2024-01-19 21:30:47 -0800
commitcb76e5cd81312e4dba52a06cfc6bc35f795e05bb (patch)
treeabc6a7e805c72b0f0f7f0123c53d45e2f4d82c3f /CMakeLists.txt
parent0c3b5ac16daf929ca018ad3cdac08123b4d2bedc (diff)
downloadwabt-cb76e5cd81312e4dba52a06cfc6bc35f795e05bb.tar.gz
wabt-cb76e5cd81312e4dba52a06cfc6bc35f795e05bb.tar.bz2
wabt-cb76e5cd81312e4dba52a06cfc6bc35f795e05bb.zip
Fix emscripten build warning and add missing export (#2367)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 63f971f7..5b90b50b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -823,6 +823,7 @@ if (EMSCRIPTEN)
-sMODULARIZE=1
-sEXPORT_NAME=WabtModule
-sWASM=0
+ -sEXPORTED_RUNTIME_METHODS=writeAsciiToMemory
-Oz
)
string(REPLACE ";" " " LIBWABT_LINK_FLAGS_STR "${LIBWABT_LINK_FLAGS}")