summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWouter van Oortmerssen <aardappel@gmail.com>2019-12-09 17:03:18 -0800
committerGitHub <noreply@github.com>2019-12-09 17:03:18 -0800
commite098f4c22f4630dab830a032612532ab7baa9ff9 (patch)
treee8a0e132bb219d8efc77d0bbe2aaf19dbb438b31 /CMakeLists.txt
parent4191fc9e5d65f31ca7538b2a585d251b3ba07ac3 (diff)
downloadwabt-e098f4c22f4630dab830a032612532ab7baa9ff9.tar.gz
wabt-e098f4c22f4630dab830a032612532ab7baa9ff9.tar.bz2
wabt-e098f4c22f4630dab830a032612532ab7baa9ff9.zip
wasm-decompile: Load/Store tracking for struct output. (#1258)
This tries to make code more readable by summarizing patterns of load/store ops into "struct" declarations. Initial version, can probably be improved, but has all essentials of the idea in place.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5b3a4370..10e30d77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -246,7 +246,8 @@ add_library(wabt STATIC
src/config.h
src/config.cc
src/decompiler.h
- src/decompiler-ast.inl
+ src/decompiler-ast.h
+ src/decompiler-ls.h
src/decompiler.cc
src/error-formatter.h
src/error-formatter.cc