summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Clegg <sbc@chromium.org>2019-11-22 00:21:56 -0800
committerGitHub <noreply@github.com>2019-11-22 00:21:56 -0800
commite9b42933377814248b64c4fed9f58bae219443c6 (patch)
treecdc0817d68399ea0f6a2a3f758cd33eb5a1d49b2 /CMakeLists.txt
parent1eba845b3abbf7fcc2d49b76198bdc3a563fc698 (diff)
downloadwabt-e9b42933377814248b64c4fed9f58bae219443c6.tar.gz
wabt-e9b42933377814248b64c4fed9f58bae219443c6.tar.bz2
wabt-e9b42933377814248b64c4fed9f58bae219443c6.zip
Fix run-tests target on windows (#1247)
Under windows binaries end with `.exe` and live a the `Debug` or `Release` subdirectory so we need to use $<TARGET_FILE> to get the full executable name.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1d4d54c7..6452dc85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -499,8 +499,8 @@ if (NOT EMSCRIPTEN)
find_package(PythonInterp 2.7 REQUIRED)
set(RUN_TESTS_PY ${WABT_SOURCE_DIR}/test/run-tests.py)
add_custom_target(run-tests
- COMMAND ${CMAKE_BINARY_DIR}/wabt-unittests
- COMMAND ${PYTHON_EXECUTABLE} ${RUN_TESTS_PY} --bindir ${CMAKE_BINARY_DIR}
+ COMMAND $<TARGET_FILE:wabt-unittests>
+ COMMAND ${PYTHON_EXECUTABLE} ${RUN_TESTS_PY} --bindir $<TARGET_FILE_DIR:wat2wasm>
DEPENDS ${WABT_EXECUTABLES}
WORKING_DIRECTORY ${WABT_SOURCE_DIR}
${USES_TERMINAL}