summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSteven Johnson <srj@google.com>2020-06-18 12:56:30 -0700
committerGitHub <noreply@github.com>2020-06-18 12:56:30 -0700
commitf80108f417951064f6082dd2bfc52d6af75a8e65 (patch)
tree2a1498c510d25274317062926a00981b369d4af6 /CMakeLists.txt
parent1467a6113414e7ef24174f51398079c9f4eeae57 (diff)
downloadwabt-f80108f417951064f6082dd2bfc52d6af75a8e65.tar.gz
wabt-f80108f417951064f6082dd2bfc52d6af75a8e65.tar.bz2
wabt-f80108f417951064f6082dd2bfc52d6af75a8e65.zip
Improve CMakeLists.txt for when used via add_subdirectory() (#1467)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 14 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3451ed78..dd12d663 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,12 @@ project(WABT VERSION 1.0.13)
set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
+# Check if wabt is being used directly or via add_subdirectory, FetchContent, etc
+set(WABT_MASTER_PROJECT OFF)
+if (CMAKE_CURRENT_SOURCE_DIR STREQUAL CMAKE_SOURCE_DIR)
+ set(WABT_MASTER_PROJECT ON)
+endif()
+
# For git users, attempt to generate a more useful version string
if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git)
find_package(Git QUIET REQUIRED)
@@ -26,11 +32,17 @@ if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/.git)
"${GIT_EXECUTABLE}" --git-dir=${CMAKE_CURRENT_SOURCE_DIR}/.git describe --tags
RESULT_VARIABLE
GIT_VERSION_RESULT
+ ERROR_VARIABLE
+ GIT_VERSION_ERROR
OUTPUT_VARIABLE
GIT_VERSION
OUTPUT_STRIP_TRAILING_WHITESPACE)
if (${GIT_VERSION_RESULT})
- message(WARNING "Error running git describe to determine version")
+ # Don't issue warning if we aren't the master project;
+ # just assume that whoever included us knows the version they are getting
+ if (WABT_MASTER_PROJECT)
+ message(WARNING "${GIT_VERSION_ERROR} Error running git describe to determine version")
+ endif()
else ()
set(CMAKE_PROJECT_VERSION "${CMAKE_PROJECT_VERSION} (${GIT_VERSION})")
endif ()
@@ -482,7 +494,7 @@ endif ()
# Python 3.5 is the version shipped in Ubuntu Xenial
find_package(PythonInterp 3.5)
if(BUILD_TESTS AND (NOT PYTHONINTERP_FOUND))
- set(BUILD_TESTS OFF)
+ set(BUILD_TESTS OFF)
message(WARNING "Skipping tests. Python 3 is required for wabt testing. Please install python3 to run tests.")
endif()