summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWouter van Oortmerssen <aardappel@gmail.com>2019-10-24 08:08:25 -0700
committerGitHub <noreply@github.com>2019-10-24 08:08:25 -0700
commitffefb3ba2cdfca91fd20a8ac99c668f80140760d (patch)
treec9bc8b910dfb2623d3e800f7fdc747565d3d6b05 /CMakeLists.txt
parent73f141d49a8759993e0a79c3a0e86dd23784378c (diff)
downloadwabt-ffefb3ba2cdfca91fd20a8ac99c668f80140760d.tar.gz
wabt-ffefb3ba2cdfca91fd20a8ac99c668f80140760d.tar.bz2
wabt-ffefb3ba2cdfca91fd20a8ac99c668f80140760d.zip
wasm-decompile: Added initial tests. (#1195)
These are pretty minimal, more will be added as part of feature-PRs.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 6 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4cca9006..6e4fea6a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -27,7 +27,6 @@ option(USE_UBSAN "Use undefined behavior sanitizer" OFF)
option(CODE_COVERAGE "Build with code coverage enabled" OFF)
option(WITH_EXCEPTIONS "Build with exceptions enabled" OFF)
option(WERROR "Build with warnings as errors" OFF)
-option(WIP_TOOLS "Build Work-In-Progress functionality" OFF)
if (CMAKE_C_COMPILER_ID MATCHES "Clang")
set(COMPILER_IS_CLANG 1)
@@ -432,14 +431,12 @@ if (NOT EMSCRIPTEN)
INSTALL
)
- if (WIP_TOOLS)
- # wasm-decompile
- wabt_executable(
- NAME wasm-decompile
- SOURCES src/tools/wasm-decompile.cc
- INSTALL
- )
- endif()
+ # wasm-decompile
+ wabt_executable(
+ NAME wasm-decompile
+ SOURCES src/tools/wasm-decompile.cc
+ INSTALL
+ )
endif ()
find_package(Threads)