summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fba3fd93..0e6ffb36 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,6 +191,8 @@ else ()
set(TARGET_ARCH "i386")
elseif (${FILE_OUTPUT} MATCHES "ARM")
set(TARGET_ARCH "ARM")
+ elseif (${FILE_OUTPUT} MATCHES "IBM S/390")
+ set(TARGET_ARCH "s390x")
else ()
message(WARNING "Unknown target architecture!")
endif ()
@@ -205,6 +207,9 @@ else ()
# wasm doesn't allow for x87 floating point math
add_definitions(-msse2 -mfpmath=sse)
endif ()
+ if (TARGET_ARCH STREQUAL "s390x")
+ add_definitions(-DWABT_BIG_ENDIAN=1)
+ endif ()
endif ()
endif ()