summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 48812d13..2bfe62a8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -164,7 +164,7 @@ else ()
# interfaces, etc.
# disable -Wpointer-arith: this is a GCC extension, and doesn't work in MSVC.
add_definitions(
- -Wall -Wextra -Wno-unused-parameter -Wpointer-arith -Wuninitialized
+ -Wall -Wextra -Wno-unused-parameter -Wpointer-arith -Wuninitialized -Wimplicit-fallthrough
)
set(CMAKE_CXX_EXTENSIONS OFF)
@@ -563,7 +563,9 @@ if (BUILD_TOOLS)
if (COMPILER_IS_GNU)
target_compile_options(uv_a PRIVATE "-Wno-sign-compare")
- endif ()
+ elseif (COMPILER_IS_CLANG)
+ target_compile_options(uv_a PRIVATE "-Wno-implicit-fallthrough")
+ endif()
endif()
# wasm-interp