summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHenrique Alves <henrique.alves@itsjungle.xyz>2024-04-24 02:44:33 +0300
committerHenrique Alves <henrique.alves@itsjungle.xyz>2024-04-24 02:44:33 +0300
commit150738de9fb42159f6b60bc5cf817d99e6718988 (patch)
tree78202018253cd3771784872898688a675ce52dcb /CMakeLists.txt
parent1d579be7f2469afdc2074af29d96dece70a62daa (diff)
downloadgamejam-slgj-2024-150738de9fb42159f6b60bc5cf817d99e6718988.tar.gz
gamejam-slgj-2024-150738de9fb42159f6b60bc5cf817d99e6718988.tar.bz2
gamejam-slgj-2024-150738de9fb42159f6b60bc5cf817d99e6718988.zip
Successful test with s7!
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 1 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b41afcb..f649d60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,13 +24,11 @@ FetchContent_MakeAvailable(raylib)
file(GLOB_RECURSE PROJECT_SOURCES CONFIGURE_DEPENDS "${CMAKE_CURRENT_LIST_DIR}/sources/*.c") # Define PROJECT_SOURCES as a list of all source files
set(PROJECT_INCLUDE "${CMAKE_CURRENT_LIST_DIR}/sources/") # Define PROJECT_INCLUDE to be the path to the include directory of the project
-pkg_check_modules(GUILE_PKG REQUIRED IMPORTED_TARGET guile-3.0)
-
# Declaring our executable
add_executable(${PROJECT_NAME})
target_sources(${PROJECT_NAME} PRIVATE ${PROJECT_SOURCES})
target_include_directories(${PROJECT_NAME} PRIVATE ${PROJECT_INCLUDE})
-target_link_libraries(${PROJECT_NAME} PRIVATE raylib PkgConfig::GUILE_PKG)
+target_link_libraries(${PROJECT_NAME} PRIVATE raylib)
# Checks if OSX and links appropriate frameworks (Only required on MacOS)
if (APPLE)