summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorHenrique Alves <henrique.alves@itsjungle.xyz>2024-04-25 14:20:17 +0300
committerHenrique Alves <henrique.alves@itsjungle.xyz>2024-04-25 14:20:17 +0300
commit97168aaf30c64c688e0057f28f1f2375b4c40520 (patch)
tree9f48d9caace322a99e47600a717725079334403a /CMakeLists.txt
parent3febad74e46d3485f079108b2d30bcde1f6ce58b (diff)
downloadgamejam-slgj-2024-97168aaf30c64c688e0057f28f1f2375b4c40520.tar.gz
gamejam-slgj-2024-97168aaf30c64c688e0057f28f1f2375b4c40520.tar.bz2
gamejam-slgj-2024-97168aaf30c64c688e0057f28f1f2375b4c40520.zip
Fix basic counting on web
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58f137f..b192bf0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -12,10 +12,10 @@ set(BUILD_EXAMPLES OFF CACHE BOOL "" FORCE) # don't build the supplied examples
set(BUILD_GAMES OFF CACHE BOOL "" FORCE) # don't build the supplied example games
FetchContent_Declare(
- raylib
- GIT_REPOSITORY "https://github.com/raysan5/raylib.git"
- GIT_TAG "master"
- GIT_PROGRESS TRUE
+ raylib
+ GIT_REPOSITORY "https://github.com/raysan5/raylib.git"
+ GIT_TAG "master"
+ GIT_PROGRESS TRUE
)
FetchContent_MakeAvailable(raylib)
@@ -44,8 +44,8 @@ if (${PLATFORM} STREQUAL "Web")
endif()
if (EMSCRIPTEN)
- set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -s USE_GLFW=3 -s ASSERTIONS=1 -s WASM=1 -s GL_ENABLE_GET_PROC_ADDRESS=1")
- set(CMAKE_EXECUTABLE_SUFFIX ".html") # This line is used to set your executable to build with the emscripten html template so that you can directly open it.
+ set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -s USE_GLFW=3 -s ASSERTIONS=1 -s WASM=1 -s GL_ENABLE_GET_PROC_ADDRESS=1 --embed-file assets --embed-file scripts")
+ set(CMAKE_EXECUTABLE_SUFFIX ".html") # This line is used to set your executable to build with the emscripten html template so that you can directly open it.
endif ()
# Setting ASSETS_PATH