summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6eba3bf..b226ac6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,4 +10,6 @@ set(BUILD_GAMES OFF CACHE BOOL "" FORCE) # or games
add_subdirectory(libs/raylib)
add_executable(raylib_template src/main.c)
-target_link_libraries(raylib_template PRIVATE raylib) \ No newline at end of file
+target_link_libraries(raylib_template PRIVATE raylib)
+target_compile_definitions(raylib_template PUBLIC ASSETS_PATH="${CMAKE_CURRENT_SOURCE_DIR}/assets/") # Set the asset path macro to the absolute path on the dev machine
+#target_compile_definitions(raylib_template PUBLIC ASSETS_PATH="relative-path-to-assets-in-the-game-package") # Set the asset path macro in release more \ No newline at end of file