summaryrefslogtreecommitdiff
path: root/libs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/CMakeLists.txt')
-rw-r--r--libs/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/libs/CMakeLists.txt b/libs/CMakeLists.txt
new file mode 100644
index 0000000..4b4489c
--- /dev/null
+++ b/libs/CMakeLists.txt
@@ -0,0 +1,9 @@
+set(BUILD_SHARED_LIBS OFF) # link third party libraries statically
+
+# raylib
+if(NOT EXISTS "${CMAKE_CURRENT_SOURCE_DIR}/raylib")
+ message(FATAL_ERROR "Could not find raylib folder. Did you clone the Git submodules?")
+endif()
+
+add_subdirectory(raylib)
+target_compile_options(raylib PRIVATE "-w") # disable warnings