summaryrefslogtreecommitdiff
path: root/libs/raylib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/raylib/CMakeLists.txt')
-rw-r--r--libs/raylib/CMakeLists.txt57
1 files changed, 18 insertions, 39 deletions
diff --git a/libs/raylib/CMakeLists.txt b/libs/raylib/CMakeLists.txt
index be74c4d..5fe826d 100644
--- a/libs/raylib/CMakeLists.txt
+++ b/libs/raylib/CMakeLists.txt
@@ -1,54 +1,33 @@
cmake_minimum_required(VERSION 3.0)
+project(raylib)
+
+# Directory for easier includes
+# Anywhere you see include(...) you can check <root>/cmake for that file
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake)
-# Config options
-option(BUILD_EXAMPLES "Build the examples." ON)
-option(BUILD_GAMES "Build the example games." ON)
-option(ENABLE_ASAN "Enable AddressSanitizer (ASAN) for debugging (degrades performance)" OFF)
-option(ENABLE_UBSAN "Enable UndefinedBehaviorSanitizer (UBSan) for debugging" OFF)
-option(ENABLE_MSAN "Enable MemorySanitizer (MSan) for debugging (not recommended to run with ASAN)" OFF)
-
-if(CMAKE_VERSION VERSION_LESS "3.1")
- if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
- set(CMAKE_C_FLAGS "-std=gnu99 ${CMAKE_C_FLAGS}")
- endif()
+# RAYLIB_IS_MAIN determines whether the project is being used from root
+# or if it is added as a dependency (through add_subdirectory for example).
+if ("${CMAKE_SOURCE_DIR}" STREQUAL "${CMAKE_CURRENT_SOURCE_DIR}")
+ set(RAYLIB_IS_MAIN TRUE)
else()
- set (CMAKE_C_STANDARD 99)
+ set(RAYLIB_IS_MAIN FALSE)
endif()
-include(AddIfFlagCompiles)
-add_if_flag_compiles(-Werror=pointer-arith CMAKE_C_FLAGS)
-add_if_flag_compiles(-Werror=implicit-function-declaration CMAKE_C_FLAGS)
-# src/external/jar_xm.h does shady stuff
-add_if_flag_compiles(-fno-strict-aliasing CMAKE_C_FLAGS)
-
-include(CheckFileSystemSymlinkSupport)
+# Sets compiler flags and language standard
+include(CompilerFlags)
-if (ENABLE_ASAN)
- add_if_flag_compiles(-fno-omit-frame-pointer CMAKE_C_FLAGS CMAKE_LINKER_FLAGS)
- add_if_flag_compiles(-fsanitize=address CMAKE_C_FLAGS CMAKE_LINKER_FLAGS)
-endif()
-if (ENABLE_UBSAN)
- add_if_flag_compiles(-fno-omit-frame-pointer CMAKE_C_FLAGS CMAKE_LINKER_FLAGS)
- add_if_flag_compiles(-fsanitize=undefined CMAKE_C_FLAGS CMAKE_LINKER_FLAGS)
-endif()
-if (ENABLE_MSAN)
- add_if_flag_compiles(-fno-omit-frame-pointer CMAKE_C_FLAGS CMAKE_LINKER_FLAGS)
- add_if_flag_compiles(-fsanitize=memory CMAKE_C_FLAGS CMAKE_LINKER_FLAGS)
-endif()
+# Registers build options that are exposed to cmake
+include(CMakeOptions.txt)
-if (ENABLE_MSAN AND ENABLE_ASAN)
- MESSAGE(WARNING "Compiling with both AddressSanitizer and MemorySanitizer is not recommended")
-endif()
+# Enforces a few environment and compiler configurations
+include(BuildOptions)
-add_subdirectory(src)
+# Main sources directory (the second parameter sets the output directory name to raylib)
+add_subdirectory(src raylib)
if (${BUILD_EXAMPLES})
+ MESSAGE(STATUS "Building examples is enabled")
add_subdirectory(examples)
endif()
-if (${BUILD_GAMES})
- add_subdirectory(games)
-endif()
-
enable_testing()