summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2012-05-20 15:23:52 -0500
committerJohn Wiegley <johnw@newartisans.com>2012-05-20 15:23:52 -0500
commit1b1c7cd4ac9efe9f44b31513a33dc68bf6ee1924 (patch)
treec36e4190510474bececa37e657f659caed5aa7ae /CMakeLists.txt
parentf579e6ddacb08ffeb124a9ec87b7faf7e9683a3c (diff)
downloadfork-ledger-1b1c7cd4ac9efe9f44b31513a33dc68bf6ee1924.tar.gz
fork-ledger-1b1c7cd4ac9efe9f44b31513a33dc68bf6ee1924.tar.bz2
fork-ledger-1b1c7cd4ac9efe9f44b31513a33dc68bf6ee1924.zip
A few more CMake-related fixes
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 046e9b05..6e845b01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,15 +24,9 @@ option(BUILD_EMACSLISP "Build and install ledger-mode for Emacs" OFF)
if(BUILD_DEBUG)
set(CMAKE_BUILD_TYPE Debug)
set(DEBUG_MODE 1)
- set(NDEBUG 0)
-elseif(NO_ASSERTS)
- set(CMAKE_BUILD_TYPE Release)
- set(DEBUG_MODE 0)
- set(NDEBUG 1)
else()
set(CMAKE_BUILD_TYPE Release)
set(DEBUG_MODE 0)
- set(NDEBUG 0)
endif()
########################################################################