summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 046e9b05..6e845b01 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -24,15 +24,9 @@ option(BUILD_EMACSLISP "Build and install ledger-mode for Emacs" OFF)
if(BUILD_DEBUG)
set(CMAKE_BUILD_TYPE Debug)
set(DEBUG_MODE 1)
- set(NDEBUG 0)
-elseif(NO_ASSERTS)
- set(CMAKE_BUILD_TYPE Release)
- set(DEBUG_MODE 0)
- set(NDEBUG 1)
else()
set(CMAKE_BUILD_TYPE Release)
set(DEBUG_MODE 0)
- set(NDEBUG 0)
endif()
########################################################################